�Internet Assistant for PowerPoint(


�The PowerPoint 95 to World Wide Web Document Converter  





Congratulations, you already know enough to make great Web pages.





As a PowerPoint for Windows 95 user, you have one of the most popular and powerful graphics communications packages available. You know that with its popular templates, clip art, color schemes, and outlining, you can quickly put together a presentation that communicates your message in a professional style. And now, with a free add-in—the Internet Assistant for PowerPoint—you’re just a few quick clicks from putting that same great presentation out on the World Wide Web.





So what is a Web page? It’s simply text files composed of special commands that format text and pictures in a Web browser. One advantage of a Web page is that its content can be linked to other pages by what is called a hyperlink. When you click a hyperlink in your Web browser, you automatically move to the linked page.





This sounds a lot like a PowerPoint presentation, doesn’t it? They’re similar types of documents, and the data in Web pages is often similar to what you create in a presentation. Microsoft has created the Internet Assistant for PowerPoint add-in to help you convert your PowerPoint presentations to Web documents.





The Internet Assistant for PowerPoint add-in adds the single command Export as HTML to your PowerPoint File menu. HTML (HyperText Markup Language) is the language of the World Wide Web. Creating an HTML version of your presentation is just a matter of clicking the new command, typing a name for your project, and then clicking OK. There’s no need to work in HTML because the Internet Assistant does all the coding for you.





How does it work? The Internet Assistant uses your presentation to create a new set of linked HTML documents, ready for the Web. You get two versions of each slide, one graphic and one text. The text version is useful for Web browsers that can’t view graphics, and it’s faster to “flip through” a text version of slides. The graphic version maintains the color scheme and appearance of your original presentation. Because the Internet Assistant creates “client side image maps” of your original slides, both versions maintain the PowerPoint interactive settings that jump to other slides or documents. In simpler terms, if clicking an oval on slide 1 takes you directly to slide 5 in the original presentation, that’s what’ll happen in the HTML version.





So, let’s get started. If you’re feeling adventurous, you’ll be reassured to know the process is simple enough to figure out by yourself. You might even want to jump ahead to a couple of sections near the end of this document—“Hints for Creating PowerPoint Presentations” and “Getting More out of the Internet Assistant for PowerPoint.” 
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Installing the Internet Assistant for PowerPoint


Before you begin, make sure you’ve installed PowerPoint for Windows 95. The Internet Assistant won’t work with PowerPoint 4.0 or earlier versions. If multiple users share a computer, you’ll need to install an Internet Assistant for each user needing this functionality. You must also be able to write to your PowerPoint directory, so some network installations and “run from CD” installations won’t be able to use this add-in.





Close PowerPoint if it’s running.


Double click the ia4ppt95.exe application.


Follow the instructions on the screen.





When Setup is complete, start PowerPoint and notice the new Export as HTML command on the File menu.


Step by Step with the Internet Assistant for PowerPoint


This section leads you through the procedure for converting your PowerPoint presentation to an HTML document. It assumes you’ve installed the Internet Assistant for PowerPoint add-in and that the command Export as HTML appears on your PowerPoint File menu. If you don’t see this command, quit PowerPoint and review the previous section, “Installing the Internet Assistant for PowerPoint.”





Before you begin, make sure you don’t have any toolbars or dialog boxes in the top left quarter of your screen whose “always on top” option’s been set—for example, the Microsoft Office Manager or the Windows Taskbar. If you have, move them down or to the right while you export your slides.





Open the PowerPoint presentation you want to convert.


On the File menu, click Export as HTML.


Set the following options in the HTML Save Options dialog box.


Output style. Click either Grayscale or Color to indicate whether you want your slides to appear in black and white or in color. Color is the most likely choice for PowerPoint slides that use several colors.


Output format. Click either JPEG or GIF to indicate the bitmap format you want for your slides: GIF files can be slightly larger than JPEG files and still be sharp representations of your slides; JPEG files can be much smaller than GIF files, but their image fidelity will suffer at smaller sizes (see the following option).


JPEG compression quality. Move the slide control to set the quality level for JPEG format. A lower setting will result in a smaller file, but text and lines might appear blurred or streaked. If you use a lot of photographic images in your slides, JPEG files can save space and increase speed when you download your Web documents.


Folder for HTML Export. Enter the name of the drive and folder in which you want to save the files created for your Web pages. To change to a different location, type the new path or click Browse to select a new location.


Click OK.





Note: Make sure you don’t move your mouse over the slide show while your presentation’s being converted or your exported slides might display the slide show Popup Menu button. You can prevent this by doing the following: On the Tools menu, click Options, click the View tab, and then clear the Show Popup Menu Button check box.





After a few moments, you’ll see a slide show appear in a window. The Internet Assistant uses this window to convert the images of your slides. You’ll also notice that the more slides you have in your presentation and the more interactive settings you’ve set, the longer this process will take.





If you save files to the same folder again, you’ll be asked if you want to overwrite the existing files. If you’ve reduced the number of slides in your presentation, some of the earlier documents won’t be overwritten and you’ll need to delete them from the folder before moving it to your Web site. You can avoid this by creating a new project, or you can delete the earlier one before you convert the revised presentation.


Looking at the New Web Pages


Your new Web page is actually a collection of files saved in the folder you specified in the HTML Save Options dialog box. Let’s look at an example. Suppose you saved a three-slide presentation to a folder named Sales Presentation on your Windows desktop. Here’re some files you would see inside that folder:





Index.htm


Sld001.htm


Sld002.htm


Sld003.htm


Tsld001.htm


Tsld002.htm


Tsld003.htm


Sld001.gif


Sld002.gif


Sld003.gif


	


Index.htm is the start or “home page” of your presentation. When viewed with a browser, it displays the name of the presentation, your name, and your company name. The home page also lists the slides in your presentation, formatted as hyperlinks, so that clicking one of them takes you directly to that slide. If the Internet Explorer or a similar Web browser is installed on your system, you can open any of the .htm files.





Sldxxx.htm files are the Web representations of your slides. They load the Sldxxx.gif (or Sldxxx.jpeg) files into your browser.





Tsldxxx.htm files are special text-only versions of your slides in which the slide titles and any text in bulleted lists, text objects, and shapes appear. Because you often use graphics in PowerPoint to make your point, these slides might not always maintain the context of your message. You might want to consider this when creating presentations you plan to convert to Web pages.





Additional .gif files in the folder are used to display the next, previous, first page, and text view buttons on the Web pages. Because these buttons are reused from page to page, only one set needs to be in your folder. The text-only files use hyperlinked text to represent these controls.


Speaker Notes


Any speaker notes added to your presentation appear in both the Sldxxx.htm and Tsldxxx.htm files. If you don’t want these notes to appear on your Web pages, see the instructions for removing them in “Getting More out of the Internet Assistant for PowerPoint,” near the end of this document.


Hidden Slides


When you use PowerPoint for Windows 95, you have the ability to “hide” certain slides. These slides only appear in a presentation when you navigate to them by way of an interactive setting or a keyboard jump to a shortcut menu. When you create an HTML version of your presentation, however, an HTML representation is created for each slide. If you don’t want hidden slides to appear in your HTML version, you can make a copy of the presentation you want to convert, and then delete the hidden slides from the copy. Or, you might move all of your hidden slides to the end of the presentation, and then precede this section with a new slide that introduces the hidden content as reference or backup material.


Grouped Objects and Text 


If your slides contain text in grouped objects, this text won’t appear in the text-only version of your HTML documents. It will appear, however, if you remember to ungroup the objects before you convert your presentation to an HTML version.


Creating Larger or Smaller Images


The resolution of your monitor at the time you convert your presentation controls the height and width of the .gif or .jpg files created from your slides. A monitor set to 640 by 480 resolution will produce smaller bitmaps than one set to 1024 by 768. Here’s how you can temporarily raise or lower the resolution to adjust image size before you convert your presentation.





On the Start menu, point to Settings, and then click Control Panel.


Double-click Display, and then click the Settings tab.


Move the slide control to the resolution you want, and then click OK.


Moving Your Presentations to the Web


After they’re created, you’ll probably want to put your new presentation pages where others can see them. In addition to the Web—available to anyone with access—another location you might consider is a company Web server that limits access to other company employees.





If you have your own Web site, you’ll need to send your files to your file space before others can view them. The Internet Assistant assumes you’ll create a folder for each of your presentations and then create a hyperlink to the folder name. All files created for your presentation should be stored in this folder. You might also need to modify the file access permissions for this new folder and the files in it. For additional information about your environment, see your network technical support or site “WebMaster.”


Hints for Creating PowerPoint Web Presentations


The Internet Assistant for PowerPoint was created to obtain great results from all presentations. You can take advantage of this by adding settings to your presentations that will deliver great Web results as well. Here’re some things to keep in mind as you create presentations you’ll use on the Web.





Use interactive settings. The Interactive Settings command on the PowerPoint Tools menu lets you turn any PowerPoint shape into a button, which you can then use to move to another slide, document, or HTTP address. When converted, interactive settings become “client side image maps” that maintain your links between slides and other documents.


Use the common Web protocols. The HTTP, FTP, file, and mailto protocols are all supported by Internet Assistant for PowerPoint. For example, if you type “http:\\www.yahoo.com” as a Run command in the Interactive Settings dialog box for the object, the command will be preserved and properly composed when you convert the presentation to HTML.


Make sure your message appears in the text of the presentation. Consider the HTML text-only version that will be exported. Remember that slides containing only a graph or chart will have little to represent them when converted to HTML.


Make sure you don’t clutter your slides with too many distractions. A clear and easy-to-read presentation will export as an easy-to-read Web page.


Use large font sizes. Small text is typically hard to read in a presentation, and even harder when saved as a smaller bitmap.


For more ideas, read your PowerPoint documentation for tips on creating good presentations.


Getting More out of the Internet Assistant for PowerPoint


Two files added to your PowerPoint folder will give additional flexibility and control to those who know a little about HTML. This section isn’t a primer on these modifications—or on HTML in general—but does offer some ideas on how you might modify the Internet Assistant export template files to add personalized effects and customize the output.





Each HTML output version—both text and graphic—is supported by a specific template file. Image.tpl is used to compose the graphic versions of your slides, and Text.tpl is used to compose the text versions. These are standard text files that can be opened and edited with Notepad, Wordpad, or your favorite text editor.





A word of advice: Make backup copies of your .tpl files before modifying them so you can always return to the original if your modifications go wrong.





When you review the .tpl files, you’ll notice they look very much like standard HTML documents. You’ll also notice the standard HTML and TITLE and BODY tags and their closing tags later in the document. Between these tags are the placeholders for the slide image, the control buttons, and the placeholder for inserting notes in your presentation.





One particular modification you might want to consider is eliminating the slide notes from presentations you export. To do this, just eliminate the following lines:





<**NOTES**


<Font size=4> <STRONG> Notes:</FONT> </STRONG>


<HR SIZE=3>


<P> %s </P> **NOTES**>


<**TEXT*** <!-- %s  --> **TEXT***>





Or, if you simply want to be more specific in your description of this section, you might change the second line to read:





<Font size=4> <STRONG> Notes prepared for the presentation:</FONT> </STRONG>





Here’re some additional ideas for using the .tpl files.





Use Client Pull to simulate the presentation’s slide timings.


Modify the paths to the navigation buttons to your own Web site graphics directory, and then use alternate buttons.


Change the centered formatting to left or right aligned.


Modify or eliminate the table structures around the button controls.


Change the text or alternate text used in the button controls.





Troubleshooting


Error message during Setup—"Error: could not copy file."


Possible causes:


PowerPoint is running. Quit PowerPoint before running Setup.


Read-only attributes have been set on some or all files in the PowerPoint directory (Image.tpl, Pp2hintl.dll, Ppt2html.dll, Ppt2html.ppa, Setup.exe, Slidedmp.exe, Suintl.dll, Text.tpl). Correct attributes and rerun Setup.


You tried to run Setup from a DOS window from another directory.


You tried to install to a “run from CD” or network installation where you don’t have write access to the directory.  These configurations aren’t supported.





Error message during export—"Directory not created."


Possible causes:


You tried to create two or more new directories. Limit new directories to a single directory for the project. Use the Browse button to find a specific location.


You don’t have write permission on the directory or server location to which you’re writing. Confirm with your system administrator.


You typed an invalid drive letter.





Error message during export—"Not all files were saved. Delete existing files?"


You don’t have enough space on your computer. You’ll need roughly 20K to 30K per slide, converted. Free up some space on your computer and try again.





Error—Exported slides have parts of other dialog boxes clipping the exported image.


Make sure you don’t have any toolbars or dialog boxes in the top left quarter of your screen whose “always on top” option’s been set—for example, the Microsoft Office Manager or the Windows taskbar. If you have, move them down or to the right while you export your slides.�





Error—Exported slides show a funny little rectangle in the lower left of the slide.


Your slides were exported with the slide show Popup Menu button displayed. To prevent this, do the following: On the Tools menu, click Options, click the View tab, and then clear the Show Popup Menu Button check box. Now export your slides again.


Removing the Internet Assistant for PowerPoint


Follow these steps if you need to remove the Internet Assistant for PowerPoint.





Close PowerPoint if it’s running.


Delete the following files from the folder you store your PowerPoint program in:


Ppt2html.ppa


Ppt2html.dll


Slidedmp.exe


Pp2hintl.dll


Image.tpl 


Text.tpl


Additional Credits


Portions of Internet Assistant for PowerPoint are based in part on the work of


the Independent JPEG Group.
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